You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
21 lines
355 B
21 lines
355 B
with import <nixpkgs> {};
|
|
|
|
stdenv.mkDerivation {
|
|
name = "cpp-env";
|
|
nativeBuildInputs = [
|
|
gcc10
|
|
curl
|
|
cmake
|
|
ccache
|
|
rsync
|
|
unzip
|
|
|
|
# Example Build-time Additional Dependencies
|
|
pkgconfig
|
|
];
|
|
buildInputs = [
|
|
# Example Run-time Additional Dependencies
|
|
clang-tools
|
|
];
|
|
hardeningDisable = [ "format" "fortify" ];
|
|
}
|
|
|